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Introduction
This book has come about because I could not find any good information
on cheap but professional publishing using Open Source Software. For
many years I have maintained a web site providing help to normal users
and small firms. During the last three years I have moved all my own work
to Open Source software running under Linux, but this book does not
assume you have taken that step.
You may well ask - Why publish books at all these days on paper in an
interconnected electronic world? For many people it is what has come to
be called Vanity Publishing, where people like to see their name on the
cover of a book and are prepared to pay to see it happen. For me a major
part of the answer is to do with permanence, what I would term Perpetuity or Posterity Publishing. So much information these days is
transient and un-attributable. Even the best of information on web sites
does not stay for ever and is subject to change so it is difficult to quote. I
am a great fan of Wikipedia but again you do not know from day to day
what will be present on any subject. Worse still some of the technical
pages on Wikipedia are suffering from the subtle and sometimes not so
subtle effects of commercial interference as seems to have occurred on
some of the OpenSource pages. This is termed FUD and refers to the use
of Fear, Uncertainty, and Doubt that sales people instill in the minds of
potential customers who might be considering alternative products.
In contrast paper has a life of hundreds of years - I have some of the
technical books used by my grandfather, they may be slightly yellowed, but
they still give fascinating insights into science and technology a hundred
years ago. How long will our current media last and will we be able to read
they in twenty years time - have you tried to read an 8 inch or 5.25 inch (or
even a current style) floppy disk recently? Reading old books also reduces
the changes made to history by the selection mechanisms of political
correctness.
If you publish a book and obtain an ISBN number for it you will be
required to place 6 copies in copyright libraries where they will remain
accessible to all for many decades, unchanged and safe for anyone to refer
to. The intention of this book is to show how you can make sure your
little contribution to the jigsaw of life is preserved in perpetuity for
posterity for about £100 using internet based Print on Demand services
such as Lulu and an investment in a block of ISBN numbers.
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Part 1
Designing your Book with Style

1 What distinguishes a book from other
documents?
We all think we know what a book is and can instantly separate it from
any other form of document or publication until we are asked ‘What
actually distinguishes a book from any other document’?
Although there are many variations there are a few common factors and
many conventions which we will do well to follow when we turn our work
of art into a tangible book. We will look at a few of the more standard
features and their consequences on the layout.
Books are bound. The sheets of paper are bound on one edge and
printed on both sides. Therefore a book has different left and right pages.
It also means that you cannot read two pages in different parts of the
book simultaneously which has to be taken into account when you have
Contents Lists, Indexes and Pictures present.
Because a book is bound you can ‘thumb through the pages’ much
better than you can scan a web site or even a newspaper. Instead of
hyperlinks your navigation is by a Table of Contents, Index and Page
Numbers. That is the reason why book are inevitably divided up into
Chapters and the first page of every chapter can be easily identified by its
different form when scanning a book – this is true even of a novel which
is read from end to end.
Complex thick books become progressively more difficult to navigate to
where you want by just a page number. This is why many books have
additional information at the top, and sometimes bottom, of each page.
This can include the Part, Chapter Number, Chapter Title and sometimes
even subsection titles. It is surprisingly easy to find a the section by
thumbing such a book. Novels and simple books often have the Title and
Author at the top so you do not forget what you are reading when
somebody asks.
The text itself is laid out in paragraphs in a different way to, say a letter.
Most electronic documents these days break the paragraphs with an extra
blank line between them. That is very rare in a book, perhaps because
space is always at a premium. The convention is to have paragraphs
separated by indenting the first line of the next paragraph by a small
amount. The first paragraph in a chapter is normally not indented. The
first line after a major break in content may also be spaced down and
flush.
Most documents and publications with short lines have a ragged right
margin. Almost all books where the text flows steadily such as a novel
have justified text – the text is spread to reach the right margin. There is
much theoretical argument over which is actually easier to read but
reading a novel with a ragged margin just does not feel right.

Open Secrets Publishing with Style using OpenSource Software
Again almost all body text in books uses fonts called Serif. A serif is the
little extra stroke found at the end of main vertical and horizontal strokes
of some letters. Some are subtle and others may be quite pronounced and
obvious. They give additional visual clues and aid in the readability of a
typeface in a book. Fonts without serifs are called Sans Serif. Sans Serif
fonts render well on a computer screen where the resolution is low and
the clues from the serifs is lost. They may feel natural on a computer but
leave one feeling uncomfortable when reading a book, other than
technical ones, but that is never a comfortable activity. You will however
find that almost all headings are in a different font which is Sans Serif as
that increases the visual clues to the reader. All fonts used in running text
in books have variable spacing and the way a font set and the typesetting
handles that makes a huge difference to legibility
Another distinguishing feature of a book with a logical basis is the use
of different sorts of quotes. On a computer one does not notice the
difference between ‘quote’ and 'quote' but in a book the former makes the
start and end of a quote much more instinctively identified. In the same
way “quote” is never normally used, the only exception is a quote inside a
quote. Most people never notice this and if asked about single and double
quotes would not be able to tell you, but the same people will slow down
and feel uncomfortable reading a complex piece of text full of simple
quotes or double quotes.
Other common features of a book concern the layout of the pages at
the front. You always have a Title on a Right hand page so it is easily read.
Almost always the publishing details, copyright notices etc., are on the
back of the Title page so they are not in the way but easily found. Tables
of Contents, Introductions, Prefaces, Acknowledgements, and
Dedications are all grouped at the front and are on Right hand pages
which are always easier to find and scan. Indexes are always right at the
back.
The least logical of the conventions on the layout of a book concern
the numbering of pages as some of them go against the concept of easy
navigation. The numbering of what is called the Front Matter is in Roman
numerals i, ii iii, iv etc., whilst the main page numbering restarts at the first
Part or Chapter – some sense in that, but why do all the blank pages and
Page and Chapter Title pages have no number printed but remain in the
numerical sequence?
So the answer to the question ‘What actually distinguishes a book from
any other document’ is mainly a set of well refined conventions - there is
a comfortable and familiar look and feel to a book, both on the outside,
and as soon as we open it and scan even a few pages. Much of this is quite
logical and aids us in reading and navigating. Even small deviations will
make us uncomfortable without knowing why. None of these are things
they teach us at school.
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What distinguishes a book from other documents?
Capitalisation and punctuation also give us subtle
Tip clues
to improve the speed and ease of reading as
well as the sense of the passage. I always used to tell my staff
to read anything they had written out loud – there is no
better way of checking the grammar, punctuation and how
much sense it makes. You should try it!
Types of books.
There are basically two types of book and the difference is way they are
read. The first type is read once from beginning to end, the most common
example is a novel, a work of fiction. It is rare for anyone to read them a
second time or what to find there way to a particular passage. They will
have a sequence of numbered chapters and it is very rare for the chapters
to have titles, it is sometimes possible for it to be divided into parts where
there is a chronological split. This sort of book does not need or have any
tools for navigation,.that said, there may be some additions – it is not
unknown for a book to have a list of characters, a family tree or maps of
the location where it is set. It is also possible for there to be a list of
acronyms if for example, it is,a military book where weapon systems are
almost always referred to by acronyms.
The other type of book is non-fiction and is likely to be revisited, in the
case of technical and reference book many times.
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2 Requirements for typesetting a book for printing
Books, as we have discussed in the last chapter, have an interesting and
variable set of requirements when you come to format, number and title
the pages for printing even before converting them to a form which is
acceptable to publishers. It is, unfortunately, only too easy to spot many of
the Self Published books as they do not follow normal publishing
conventions and, more importantly, do not read well. You may chose for
good reason to deviate from what conventions exist but it is better to do
so consciously.
It is best to try and decide on an overall layout well before you start to
format the book and preferably when you are starting to write it - but
that advice will mostly come too late for readers of this book. The first
major publication I produced was the thesis for my doctorate and I spent
some time analysing all the others I could get hold of in my field so I
knew what layout was conventional, the breakdown of content, average
lengths of each part etc. I did that analysis at the end of the first year of
my three, going on four year research program so I could write any
background parts at an early stage and get the various drawings and
pictures produced in parallel with other talks and publications, many at
somebody else’s cost! The same planning is sensible for a book.
A piece of good advice I was given was to look in the local library and
see where your book would sit on the shelves and examine all those round
it for the format they follow with an eye to likely competition. Once on
the shelf the cover and title are both paramount in getting your book even
opened. You may feel it is worth doing an initial survey on the internet but
there is no substitute for a visit to a physical library to get your thoughts in
order.
Whatever sort of book you are writing there are some layout
conventions you will want to consider and probably follow and some
which publishers like Lulu insist that you follow if they are going to sell
books on your behalf especially with an ISBN number - they rightly
believe they need to maintain a good reputation.
By convention the ‘Sections’ that make up a Book are:
A Title page - un-numbered but in the initial Roman numerical
sequence (i, ii, iii etc)
A page often referred to as just the Verso as it is often on the back
of the title page which contains the ISBN Number, copyright
information and other standard text – the page number is not
displayed but in the initial numerical sequence (i, ii, iii etc). Strictly
any back of a page is a verso.

Requirements for typesetting a book for printing
Dedication(s) optional or may be within Acknowledgements - page
number is not displayed but in the initial numerical sequence (i, ii, iii
etc)
The Table of Contents and possible Tables of Figures - page
number not displayed on the first page of each but reflecting the
following numbered parts (Preface, Acknowledgements, Body,
Appendices, References and Index) correctly. Left and right pages
may need to be different. Numbered in the initial numerical
sequence (i, ii, iii etc)
Preface and/or Forward (optional) - numbered in the initial
numerical sequence (i, ii, iii etc) - left and right pages differ .
Acknowledgements - numbered in the initial numerical sequence
(i, ii, iii etc) - left and right pages differ
The Main Text of the book possibly broken into Parts (optional)
and definitely Chapters. The page numbering is reset to start at 1 in
Arabic 1, 2 ,3 etc). Left and Right pages have a different layout
because of the binding. Headings typically contain Title on left,
Chapter on right. The first page of each Part and Chapter are
different. The first page of chapter often forced to be a right (odd
numbered page) . The first page of a part may only have Title of the
Part and may follow a blank page with the page number not
displayed but still in the numbering sequence.
The Back Matter as it is called in the printing trade comprises some
or all of the bibliography, references, index, and appendixes
will be similar or identical in presentation to the main text but with
less information in the Header.
A Blank Final Page – it must have nothing at all on it as it used by
some printers to overlay information.
The main differences you will find are in the number of different
‘sections’ that are present and how they are broken up. Some books will
have quite a few blank pages so that the starts of the various sections are
on a new page and on the right hand page. The may want to have a new
part start on a right hand page and have the following Chapter also start
on a right hand page. Starting all Chapters on a right hand page is
common but does add many blank pages. If the book will be produced
only as an eBook or in parallel with a real book then you will want to keep
empty pages to an absolute minimum or remove them altogether in the
eBook version.
The parts that make up a page are:
A Header at the top which is to some extent repetitive or blank on
some pages
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The Body in the middle has the text flowing through from page to
page until broken by the end of part, chapter or other construct
which needs to start on a new page.
A Footer at the bottom which is likely to be blank or just contain a
page number
Header and Footer Contents
The information which will be found in the header/footer will include
the Book Title, the Author and possibly the Chapter Title along with the
page number and possibly a horizontal lines to separate it from the body.
This is an import way that people navigate a book and find a section by
thumbing or scanning.
Page Numbering:
A Page Number can be in the header or footer and may differ in
position in a left, right or chapter heading page.
The ‘Front Part’ (everything before the main text) will be numbered
sequentially in Roman.
Numbering will restart in Arabic for the main text and continue in
Arabic into the ‘Back Matter’ (bibliography, references, index, and
appendixes etc).
The page number may not be displayed on some pages such as
blank pages and the title/heading pages for Parts and Chapters but
you must maintain the sequence - ie the page still has a number but
it is just not displayed.
There seems to be no standards other than page numbers must be in a
numerical sequence. Have a look at books in a similar area to which you
intend to publish and there may be a consensus within that area you could
follow.
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3 The Outline of a Book
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It is worth while creating an outline of some form early on to which you
can add information as you progress. The is an example of what I have
done in the past and please note I have included columns marked Style
which I will explain in due course.
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As the book progresses and your thoughts firm up you can fill in more of
the table. You may then decide you need to bring out more on the
Appendices and maybe format them differently, perhaps more like the
Chapters or you may want to add an Index. You can however at any time
get an idea of the overheads you are adding in forcing starts to be on the
right and other sources of blank pages.
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4 Separating the Amateurs from the Professionals
This chapter is a check list of format and layout problems which can be
seen on a quick thumb through a book by a purchaser at a bookshop or
by a well clued up purchaser looking at the excerpts that are on web sites
when a book is for sale.
Availability of Information

Correct information on the Verso of the Title Page. Does the book
have an ISBN and a credible looking publisher and printer.
Page Layout

Text not too close to the edge of the page because of cropping or,
worse still too close to the binding so it is difficult to read. Too many
Widows and Orphans. (Single lines at top or bottom of page).
Paragraph format.

There should not be Lines between every paragraphs. Look out for
poorly sized indents at the start of a paragraph – they should be the size
in points of the text. There should be Indents on the first paragraph in
the text and after a table or drawing. Ragged right text.
Text layout

Extra spaces between sentences and spaces at the start of paragraphs.
Too much hyphenation or huge gaps in justified text - this may need hand
crafting on a final look through especially on any preview pages.
Fonts

Use of a Sans Serif fonts for running text. Too many different fonts. A
lot of use of bold text. Use of default fonts eg Times New Roman and
Arial.
Quotes

The old conventions were that Single smart Quotes should be used
except for within quoted text but increasingly that is being broken so it
should not be held against an author.
Numbers

Numbers up to twenty should be written out in full – numbers over that
can be Arabic numbers such as 23
Spelling and Grammar

There should be no excuses spelling errors now that a spell checker is
built into every word processor but make sure you have it set to the local
language rather than US. Also watch for misuse of words, there and their
for example. Avoid sentences which are too long or short and/or very
long paragraphs. Watch for incorrect Capitalisation and lack of
punctuation.
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Pictures and Graphics

Poor choice of size. Poor quality. No captions or figure numbering.
References to pictures or graphics as below, above or beside rather than
use of automatic numbering.
Index

No index on the sort of book where it would be expected eg
biographies and technical books.
Consistency

I put this in as we discovered that the page numbers were a slightly
different font size during our checking of the proof copies of one of our
books and this could equally apply to header and footer text or even a
small mismatch in different styles.
The above are all matters which are best addressed while you are writing
and cross checked by at least one independent proof reader at the end.
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5 The Requirements
We now have a pretty good idea of what we need to do to turn ones basic
material into a book you will be proud of – a production with Style as well
as content. Style is a word with several meanings and the title of this book
is too some extent a play on words. Our objective is a book with style, an
elegant piece of work, but we will extensively use Styles which are a
mechanism used to give consistency to use of software for typesetting.
The concept of Styles is simple and elegant, what we want the book to be.
We have looked at what we need to give consistent appearance to the
pages and the text they hold both in individual parts of the text and in the
flow between them. We have seen that the first page of a chapter is
different but is always followed by mirrored pages where left and right
may be different but follow in sequence. We have seen that every chapter
has a heading which is followed by an initial paragraph without an indent
after which the sequence continues with paragraphs with the first line
slightly indented.
What we need is a mechanism where we can define the Headings and
following paragraphs so that if we need to make a change they all change
and the same with pages so we only need to change a few numbers to
change the size of a book and a few parameters to change the fonts
throughout the book - a mechanism where the format takes place
automatically as we write.
We need to associate all our typesetting information to each area of the
book in an appropriate manner. A page needs to have information on the
overall dimensions and the areas available for text and what they can hold
and also what type of page comes next. The same for paragraphs where
details of the text such as fonts, text sizes and indents, and what sort of
paragraph follows by default. We need some types of paragraphs for
Headings which also link to other areas such as a Table of Contents and
some which are special for blocks of text for Tips. In a book such
information will be reused between a dozen and several hundred times.
This information is commonly called a Style. Most web pages now use
Cascading Style Sheets to define their presentation and give consistency
between every web page on a site. Likewise major Word Processors such
as Microsoft Word and OpenOffice offer Styles although few users make
deliberate use of them. They will make our job much easier and once the
initial work is done the book will automatically adapt to any changes,
reordering or new text. A whole novel might need less than ten Styles to
define it completely. This book which has a complex hierarchical levels of
Headings and Contents Tables uses about thirty of which sixteen have
been customised. The Styles can, of course, be re-used for other books –
the changes for a different size of book could be done in a few minutes.

Part 2
Preparing your Book for Printing using Open
Source Software

6 So What is Open Source?
What does Open Source Software really mean?
To most people the most important fact about Open Source Software is
they get the software for free but that is only a small part of the story.
Open Source has many other important advantages. But firstly I should
spend a little time dispelling the impression that because it is free it must
be inferior to something organisations and people are prepared to pay a
lot of money for.
The term Open Source Software is comparatively recent and was
brought in to replace the term free software which is often not quite what
it says and, at best, is ambiguous and certainly a term the corporate world
cannot understand. An important point is that the free referred to is free
as in freedom not just free as in a free beer. In general all the source code
of all Open Source Software is accessible and anyone can make their own
modifications. Much of the best Open Source Software has good free
support from volunteers and enthusiasts and often there is commercial
support also available for firms which employ it.
Open-source software generally allows anybody to make a new version
of the software, port it to new operating systems and processor
architectures, share it with others or market it. The aim of open source is
to let the product be more understandable, modifiable, duplicable, reliable
or simply accessible, while it is still marketable. Software developers may
want to publish their software with an Open Source License, so that
anybody may also develop the same software or understand how it works.
There is a well specified Open Source Definition which presents the
open-source philosophy, and further defines a boundary on the usage,
modification and redistribution of open-source software.
The Official Open Source Definition
Introduction

Open source doesn’t just mean access to the source code. The
distribution terms of open-source software must comply with the
following criteria:
1. Free Redistribution

The license shall not restrict any party from selling or giving away
the software as a component of an aggregate software distribution
containing programs from several different sources. The license shall
not require a royalty or other fee for such sale.
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2. Source Code

The program must include source code, and must allow distribution
in source code as well as compiled form. Where some form of a
product is not distributed with source code, there must be a wellpublicized means of obtaining the source code for no more than a
reasonable reproduction cost preferably, downloading via the
Internet without charge. The source code must be the preferred
form in which a programmer would modify the program.
Deliberately obfuscated source code is not allowed. Intermediate
forms such as the output of a preprocessor or translator are not
allowed.
3. Derived Works

The license must allow modifications and derived works, and must
allow them to be distributed under the same terms as the license of
the original software.
4. Integrity of The Author’s Source Code

The license may restrict source-code from being distributed in
modified form only if the license allows the distribution of “patch
files” with the source code for the purpose of modifying the
program at build time. The license must explicitly permit
distribution of software built from modified source code. The
license may require derived works to carry a different name or
version number from the original software.
5. No Discrimination Against Persons or Groups

The license must not discriminate against any person or group of
persons.
6. No Discrimination Against Fields of Endeavour

The license must not restrict anyone from making use of the
program in a specific field of endeavour. For example, it may not
restrict the program from being used in a business, or from being
used for genetic research.
7. Distribution of License

The rights attached to the program must apply to all to whom the
program is redistributed without the need for execution of an
additional license by those parties.
8. License Must Not Be Specific to a Product

The rights attached to the program must not depend on the
program’s being part of a particular software distribution. If the
program is extracted from that distribution and used or distributed
within the terms of the program’s license, all parties to whom the

- 22 -

So What is Open Source?
program is redistributed should have the same rights as those that
are granted in conjunction with the original software distribution.
9. License Must Not Restrict Other Software

The license must not place restrictions on other software that is
distributed along with the licensed software. For example, the license
must not insist that all other programs distributed on the same
medium must be open-source software.
10. License Must Be Technology-Neutral

No provision of the license may be predicated on any individual
technology or style of interface.
You may well ask ‘why do we need licenses at all for Open Source
Software?’ The answer is that they overcome the problems of inherent
rights in our legal framework which would prevent many of the good
intentions of Open Source. Licenses are often employed to grant rights to
users which would otherwise be prohibited by copyright. These include
rights on usage, modification and redistribution. Several open-source
software licenses have qualified within the boundary of the Open Source
Definition. The most prominent example is the popular GNU General
Public License (GPL). While Open Source presents a way to broadly make
the sources of a product publicly accessible, the Open Source licenses
allow the authors to fine tune such access.
Linux is probably the best example of Open Source Software, the Linux
Kernel and almost all the software for Linux is provided under the GNU
GPL (General Purpose License). GNU is a recursive acronym going back
to the early days of the search for an operating system to replace Unix and
stands for GNU is Not Unix. Linux (strictly called GNU/Linux) is that
replacement. The huge user community and inspection of all the openly
available code means that problems are quickly identified and fixed in
Linux giving a far more safe and secure environment than Microsoft’s
Windows system which has been plagued by ever increasing security
issues. There are also many firms which provide tailored Linux systems
and the full backup and support that a commercial enterprise requires and
they feed everything back into the code base. Red Hat, Suse, Debian and
Ubuntu are now almost as familiar names as Microsoft and Apple in the
corporate world yet still put all their work back into the public domain. All
benefit especially the end users whether they are a home user, a large
corporation or a government organisation. Most of the web servers and
other software required to provide us with a reliable Internet are run
under Linux and there is increasing use on the desktop and in netbooks.
The Firefox browser is probably the best known and used example of
Open Source Software on the desktop to most users. Firefox is now used
by 40% of all users in Europe which is remarkable as almost every
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machine comes by default with some version of Microsoft’s Internet
Explorer pre-installed. It is much more difficult to get similar figures for
OpenOffice and OpenOffice’s share of the market – Microsoft claim 95%
of corporate users is based on Revenue but OpenOffice and LibreOffice
are free! Microsoft also claim 400m of its Office suites are in use. In
contrast 110m copies of OpenOffice were downloaded in addition to
other sources of distribution. That is not to say that all those copies are in
use but few people undertake 150Mbyte downloads with no intention of
using them.
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7 What Tools are available.
Word Processors
The most important tool for an author is a word processor and the
OpenOffice/LibreOffice Writer is a perfect tool. Many people think of
OpenOffice as free version of Microsoft’s Word and feel it should
therefore be inferior in some way. That is not the case and in many
respects the OpenOffice Writer is superior. The situation with
OpenOffice is becoming slightly confused as most people have switched
to LibreOffice which is closely based on OpenOffice because there were
some questions over OpenOffice's future as pure Open Source.
LibreOffice is being developed by The Document Foundation as a fork
of OpenOffice.org. The goal is to be completely vendor-independent and
without any copyright assignment requirements. The name is a hybrid
word with the first part Libre, which means free (as in freedom) in French
and Spanish, and the English word Office. One result of the fork of
OpenOffice.org into LibreOffice, and the resulting move of developers is
that Oracle has announced it is terminating commercial development of
OpenOffice.org (StarOffice). LibreOffice is now the default Office Suite
in many Linux distributions, such as Fedora, openSUSE and Ubuntu.
At this point in time I am resisting a global edit to replace every
occurrence of OpenOffice by LibreOffice and will only mention
LibreOffice if I find real differences between the two, I am now using
LibreOffice full-time including for this book and have yet to find any.
To be extended.
Graphics Tools
Most books have some pictures even if only on the cover so we will
look at suitable open Source Graphics packages. One stands out above all
other, it is Open Source, powerful, available on many operating systems
and has been developed over many years.
GIMP (The GNU Image Manipulation Program) is a free software
raster (bit mapped) graphics editor. Primarily, GIMP is used as a tool for
photo manipulations, such as resizing, editing, and cropping photos,
combining multiple images, and converting between a vast range of
different image formats. The Vision is for GIMP is to also become the
high-end graphics application for the editing and creation of original
images, icons, graphical elements of web pages and art for user interface
elements. GIMP is often cited as a replacement for Adobe Photoshop

Open Secrets Publishing with Style using OpenSource Software
although it’s maintainers state that GIMP does not aim to replicate
Photoshop. GIMP may not yet be a total replacement for high-end
commercial tools although it is beginning to gain acceptance in the
professional market. That said it has far more to offer than any normal
author will ever need and is free!
GIMP was originally created for UNIX systems; Linux, SGI IRIX and
HP-UX were supported in the first release. GIMP has been ported to
many operating systems including Microsoft Windows and Mac OS X.
I find GIMP can do everything I require but initially has a steep learning
curve as its interfaces differ from other packages. It has good help files
and some tutorials and after a day or two you will wonder how you ever
got by without it.
Typesetting – PDF Generation
OpenOffice contains its own PDF export function so, unlike Microsoft
Office one does not need additional software.
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8 Books in OpenOffice 3.0

I have spent a long time trying to get the desirable layout for Pauline’s
book with respect to the various types of pages, the Table of Contents,
Headings for the various ‘levels’ and the ability to add the chapter to the
Headers on right hand pages. This is all done by a combination of Styles
and the Outline of the document. From the start I have been using
Paragraph Styles to define the layout of each paragraph and Page Styles to
get the ‘mirror’ layout required for a book where left and right pages have
to be different because of the need to allow more margin against on the
side adjacent to the spine where the book is bound. However when I
started I did not realise the significance of the Outline.
Header 6
Header 7

9 Taming OpenOffice
Introduction
Openoffice.org Writer is a very powerful and flexible word processor,
that, like the other major players, tries to make writing documents as easy
as possible for the average user without any special configuration for the
most common activities. It also tries to make its initial set-up mimic, as
much as possible, the most common program business and most home
users will have used, namely Microsoft Word, which is part of Microsoft
Office. If you want to write standard letters you will need to do nothing
extra to get a perfectly acceptable result using the buttons on the standard
two toolbars displayed when you first turn it on and it will correct most of
the common errors you make in typing, capitalisation etc., and will tidy up
quotes, add superscripts to numbers such as 1 st and 2nd and convert
sequences such as (c) to ©.Unfortunately we are not just writing a simple
standard letter. Many of the changes which are so useful for simple tasks
are not apparent until you find it has changed something you did not
intend or anticipate.
When you are writing a book you may need to have more understanding
and control over some of the automatic changes made as you type. There
are many other options governing the behaviour and display of
OpenOffice and changes to some of these will make your life much easier
when writing a book. The need to understanding and control these
advanced features led to the title of this chapter, ‘Taming OpenOffice’. If
you do not tame OpenOffice or any other sophisticated word processor it is
possible in a couple of mouse clicks to implement thousands of changes
in a 300 page long book and even a few unexpected actions can take hours
to sort out at a latter stage.
The configuration which we are describing in this chapter comes in two
areas reached from the Tools menu namely Options and AutoCorrect In
both cases the actions are common to all the documents a user has and
does not move with a document between users or machines. It therefore
needs to be repeated if you work on both a desktop and laptop or at
home and at work. The number of important changes is however small
and can be done in a few minutes and will be an investment which will pay
back handsomely.
Reading this chapter may alone make the purchase of this book
worthwhile by saving many hours of frustration sorting out unexpected
changes and by automating other actions you would otherwise need to do
by hand.

Taming OpenOffice
Options
The first time you open the settings for Options by Tools → Options you
may well be daunted by the huge number of screens available with
everyone seemingly full of different and obscure possibilities. Fortunately
you will not need to make any changes at all on most of them. One
feature of OpenOffice which differs from many other Office suites is that
it has been developed as an integrated entity and the Options Window is
the same in all the components and what you set applies in all the
programs in the suite. You will however only see the entries that are
applicable to the current document. If the current document is a text
document, you will see the OpenOffice.org Writer entry, and the common
entries which are always visible. All your changes are automatically saved.
The display is hierarchical and to open an entry either double click this
entry or click the plus sign to the left of it. To collapse the entry, click the
minus sign or double click the entry. It is best at this point to see some
examples and we will first make a change to enhance the display of
helpful information which will immediately make the job we are doing
easier. As many readers will be reading this without a machine loaded with
OpenOffice I will shown a number of Screenshots. I would however
encourage you to parallel what I write as much as possible as Screenshots
can not display the vast amount of helpful information you will get after
this first change by hovering over any option.
We will now open up the Options Window by:
Tools → Options.
As this is our first example of an Options Screen I will go through the
display. in more detail. Depending on the version you will have little
triangles or boxes on the left which you can click to display and hide the
various groups of configuration panels in the hierarchy on the right.If you
click on the triagle/box for OpenOffice.org and click on General you will
have a display like that in Figure 1: below. I will now go through the
General screen and selected other screens in detail. In most cases the
defaults will be OK and I will not say anything when the default is OK
but you should have a look at each screen so you have a feel for all the
options which are available You can make changes on several screens
before clicking the OK button at the bottom of every screen but the
changes are active.
OpenOffice.Org Options
General Tab – On this screen it is useful to Tick the extended tool tips;
box as this gives lots of information when you hover over a button or
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option you do not understand. Figure 1: below shows the box ticked
and what the extended tool tip looks like when you hover over it.

Figure 1:
you ave ticked the Extended Toll Tips box
Tip youAftershould
click the OK button to leave Options
dialogue and then re-enter it as you will then have the
extended tool tips available to help you through setting the
rest of the Options!
User Data – You should fill in Your First/Last name and Initial as they
are used in several places including Track Changes which you may
need. Note the initials box should contain all your initials, not just he
middle one.

Figure 2
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Paths – You may want to set a path to where you keep your Documents
if they are not in a standard location.
Colors – This is where you need to come to set up any custom colours
so remember that!

Figure 3
If you define a new colour as I have done using Add you can then
modify it using Edit which gives you a palette to get the exact colour

Figure 4
Appearance – I set a different colour to the default for Page and
Column Breaks as the default does not show up very well – try Light
green or Green 8. Figure 5below.
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Figure 5
Java – This is essential for grammar checking and other Extensions. You
should select Sun Java version 1.6.0_16 or higher for the
LanguageTool grammar checker to work.See Figure 6 below.

Figure 6
Load/Save Options
General Screen It is best to use ODF Format 1.2 as the default for
saving files – do not save in Microsoft Format when writing a book as
some of the formatting you need may be changed or lost during the
conversions to and from other formats. See Figure 7 below.
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Figure 7
I have also lengthened the time for AutoRecovery saves as they take
several seconds on a large document and get intrusive if they take place
too often
Language Settings
Languages – Check it is set to the correct language
Writing Aids – The defaults should be OK but check they are what you
really want. You will need to come back here and turn on grammar
checking if you load the LanguageTool grammar checker which is
covered in Appendix D Adding a Grammar Checker to Open
Office on page 86

Figure 8
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OpenOffice Writer Options
We have now come to the Options which are specific to OpenOffice
Writer
Formatting Aids – This is an important area as it is where you set up
how potentially ‘hidden’ formatting controls, characters and fields are
displayed. They can be toggled on and off as a group by the ¶. button
on the Toolbar but you need to set the individual options here. I like
to be able to ‘see’ as many as possible of these. See Figure 9: below.

Figure 9:
Grid – The snap to grid can be useful for lining up graphics but try it
out first. I do not set it up in my defaults
Fonts – You can set the default fonts and sizes here..I have used
Garamond and Tahoma which are fonts which I have loaded specially
for books. See Figure 10: below.
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Figure 10:

AutoCaption – This is useful whilst you are adding graphics to a book
as the Caption is automatically added and scaled and updated as extra
graphics are added before and after it. See Figure 11 below.

Figure 11
AutoCorrect
This is a first introduction to AutoCorrect and I will come back to some
of its more complex use in Appendix B Converting an Existing
Document. AutoCorrect has two modes of operation, firstly
modifications whilst you are typing which can, for example, correct some
of the more common spelling errors and incorrect capitalisation. A useful
feaure is handling quotes, a standard keyboard can only insert the straight
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forward single and double quotes which look like ' and " whilst text in
books uses ‘smart’ quotes which look like ‘single’ quotes and “double
quotes”
This Automatic correction is however a double edged sword and can
cause a lot of grief if you do not know its features – if you are writing
computer code and it changes the case or type of quote it can completely
change the meaning in a case sensitive language and I you intend to print a
document you do not want URLs to have been automatically identified
and changed to blue underlined text. The suggestions that follow are
appropriate for a straight forward book but not for one including a lot of
program code.
The set up for AutoCorrect is reached by Tools → AutoCorrect and you
will be presented with a Window with 5 tabs. The first tab is Replace and
you will see that the list divides into two sorts of replacement, firstly it
gives simple ways of entering symbols such as right arrow → left arrow
← copyright © etc., and secondly the correction of common spelling
errors and mistyping.

Figure 12:
Th second tab has a large number of exceptions to try to make
automatic capitalisation work – you may want to just turn it off altogether.
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Figure 13:
The third tab is where the majority of the options are actually turned on
and off. You will see I have turned off those to do with capitalisation as I
personally find it does more harm than good for the occasional user – if
you spend your life typing one handed on moving vehicles then you may
need it.
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Figure 14:
If AutoCorrect has carried out a change you do not
Tip want
you can immediately reverse it by Ctrl z
The next tab is an important one if you are writing books as it controls
the options for Custom Quotes. This is where you can set up OpenOffice
to automatically identify when you use a single quote, either as a quotation
or as an apostrophe and change it to the appropriate single ‘curly’ quote.
You will certainly want to do this in most books in addition to identify
and changing “double quotes” as the convention is to always use single
quotes in a book unless it a quote within a quote where a character is
refering in spoken text to something said by another person.
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Figure 15:
The last tab covers Word Completion. I personally hate words just
appearing in front of me but those who use predictive text for TXTs may
love it! I have unticked the box on the tab shown in shown in Figure 16:
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Figure 16:
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10 Introduction to Styles and Paragraph Styles
There are several ways to get to the Style you want to edit - I will choose a
general way which allows one to carry out most of the operations
involving Styles you will need to do to format your book. This is to use
the Styles and Formatting floating Panel. You can toggle it on and off at
least 3 ways: by clicking on the big button to the left of the Style drop
down on the Formatting Toolbar, by F11 and by Format → Styles and
Formatting. The first is easiest. It looks like:
The first 5 buttons across the top select
between styles for paragraphs, text, frames,
pages and lists. The last button allows you to
create a new style based on the one selected.
At the bottom you can filter the styles which
are displayed - it is set to Applied which
restricts the display to those in use - at times
you may need to see them all to apply a new
style. If you want to apply a style you can
drag it onto the page, paragraph, selection
etc. When you want to edit it you right click
the style and click modify.
Figure 17
Docking the Styles and
Formatting Window
If you have a reasonably big/wide
screen it makes life very easy if you
drag the window (by the top bar) to
either side at which point it will
attach itself (dock) and the editing
area will resize to match. You can
then keep it there all the time or
toggle it by the button as above.
Docking toolbars and windows by
drag-and-drop depends on your
system’s window manager settings
and does not work in all cases. An
alternative is to Double-click inside a
vacant area of the window while
holding down the Ctrl key. In the
Styles and Formatting window,
double-click a gray part of the

Figure 18
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window next to the icons while holding down the Ctrl key. The graphic at
the left shows it docked at the left of my screen and also shows that one
can dock several tool windows at the same time if you can use drag and
drop – the tool below is another very useful tool called the Navigator and
I normally keep both docked and toggle one or both on and off as I
require.
You will probably want to check and possibly change 5 of the tabs in the
Styles and Formatting Window for paragraphs: Organiser, Indents and
Spacing, Alignment, Fonts and maybe Borders.
An Example – The Heading 3 Style used for Chapter Titles
We will now look at my requirements and how I have modified the
Header 3 Style to what I want for the chapter titles in the book.
• I want some space above and below in the style to avoid having to
add lines each time and risk inconsistencies.
• I want to chose a font, size and specify that it is, say, bold.
• I want to indent the whole chapter number and title and make
sure the text on the first and successive lines is lined up.
So I open up the Styles and Formatting Window as above, select
paragraphs (first button) right click Heading 3 and click Modify which
gives me:

Figure 19
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You will see that I am in the process of selecting one of my own Styles to
follow a Heading 3 in Figure 19- a nice touch but you can always change it
afterwards. First an easy part:

Figure 20
We have chosen Arial Bold 12pt for our chapter heading on the Font Tab
in Figure 20. Now the difficult part - indenting and lining up the text on
the subsequent lines of the title:
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You will note that the first line is brought back so the overall indent to
the chapter number is 0.6cms then all the text lines up at 1.40 cms from
the margin. There is also a vertical space of 0.52cm above the chapter title
to space it from the top margin and 0.71cm below to space it away from
the first paragraph of text which we have chosen to be my bookflush style
(which does not have any spaces on the start of the first line)
I will also show the matching Style for entries in the Table of Contents
which we will come to latter as you will need to do the same Indentation
trick in the Contents 3 Style to line everything up in the Table of Contents
even if you make no other changes.

Figure 22
Contents 5 used for other section headings has a 0.80cm indent to also
line up with the text in the ‘body’ and no difference for the first line.

- 44 -

11 Page Styles for the Book
How Page Styles Work
This section contains the basic but essential information you need to
typeset your book using OpenOffice. There is no Rocket Science here but
one finds the same questions and confusions coming up in conferences
time after time and many of the replies show those responding do not
fully understood the basics either. I will add in a couple of general facts as
well as those specific to Page Styles for a book.
1. Styles in OpenOffice are specific to one document – changes in
one of your documents will not change others.
2. Every page has a Style, when you start a New document every
page will have the Default Style.
3. Likewise every paragraph (and character) has a Style, initially a
default style.
4. If you want to reuse your Styles you can Load them from and
existing document or set up and use a Template. I cover this in
Appendix A Transferring Styles to a New Document or
Template
5. When you copy text from one document to another the Styles
may move with it. This can cause changes if you copy from
somebody else’s document – if you have unexpected effects
check for unknown Styles.
6. The style for each page contains the information on the Style
which will be used for the following page. This is crucial to the
understanding of Page Styles.
• Most Page Styles specify that the next page has the same
Style.
• Pages, for example, for Chapter headings will specify that
the following Page has a Different Style.
7. There is only one way to change this flow of page Styles through
a document and that is to insert a Manual Page Break normally
via Insert → Manual Break → Page Break and specify the new
Style
8. A Page Break entered by Ctrl Return does not allow you to
change the Page Style of the following Page.
9. You do not need to highlight the whole page, or paragraph, to
change the style.
10. Page Styles have the ability to automatically handle a book layout
which has different left and right (mirrored) pages. You do not
need to have a separate Style for left and right pages.
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An understanding of the above ten points covers almost every problem I
have had with Page Styles and the problems of other people I have read
about. Understanding all those points would have saved me days the first
time I typeset one of Pauline’s books and may well pay for this book.
Microsoft Word handles Styles slightly differently to
Tip OpenOffice.
But you import a document originally
written in Word or saved in the Word file format you may
find some unexpected effects so Do not use a Word format
for saving your book.
Word has tried to hide Styles for the beginner but this has also led to
inconsistencies which do not exist in OpenOffice. OpenOffice changes
are much more specific to the document you are working on and, for
example, it is not possible to inadvertently change the default template as
you can in Word. One problem is that the import of a complex Word
document may be handled by the generation of a large number of styles,
in one case it looked as if every chapter had been given a different page
style. One cause is that there seems to be a difference in the way that Page
Breaks are handled. Normally there are no significant anomalies and
Pauline does all her Open University marking of documents, mostly
generated in Microsoft Word and saves them back in Microsoft Word .doc
format without problems.
Setting up Page Styles for a Book.
Almost all of the setting up for your book can be done the style which
will be used for the continuation pages in each chapter. This can be used
as the basis of every other Page Style and you will only have to edit any
differences. You will definitely need a slightly different Style for the First
Page (Heading Page) of each chapter and a very slightly different page for
the Front Matter as you will need a Roman numeral in the page number.
For a novel you need no more because you can force the changes with a
few Manual Page Breaks.
On a more complex book with Appendices, References Etc., it is worth
the very small extra effort to set up six different Page Styles to cover
separate Header and Continuation pages for the Front Matter, Chapters
and Back Matter. It is however important to get the initial (Default) Style
right before you copy it. Do not be tempted to try everything out before
you are reasonably sure you have got it right so keep to the Default and
Header pages for the main chapters
If you are setting up or changing a Page Style you will want to check or
change: Organiser, Page, Header and Footer.
Organiser is important as it defines what Page Style follows - Default
will be followed by Default, a page with a Book Chapter Title (for
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example Header 3) will be followed by Default. Specially defined pages for
the Preamble and Back Matter will be followed by identical pages.
The main setting up is on the Page tab which is where you define the
size of paper, all four margins, the layout (mirrored) and Numbering (used
in page numbers etc).
The Header and Footer Tabs are self explanatory and need to be set
sensibly to match up with the margins set earlier and with other Page
Styles in use. The following is an example of the Page tab for my Default
Page Style.

Figure 23
ERROR: Above should be Width 15.6 and Height 23.4
It is best to set up the Default Page tab first the you can base the other
Page styles you use on it. I have 3 additional Styles: heading, front,
frontheading and back. Default has a Header and Footer and is used for
the body of the book. A heading page starts each 'chapter' in the body of
the book or other sections and has no Header or Footer, they are also
used for blank pages which have no footer (page number). The front
pages have Roman Numbering for the page number in the footer and no
Header and are used for the continuation pages for the Preface etc which
are placed before the main ‘chapters’ of the book start. The back pages
have no Header and Arabic numbering for the page number in the footer
and are used for the continuation of References, Acronyms etc.
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Where a Footer is present it just contains a centred page number. A
page number is inserted by Insert -> Page Number.
Where a Header is Present (ie the Default Page with a Header 3) it
contains the book title typed in on any left hand page and a right justified
Chapter Title on the right hand pages inserted by Insert -> Fields ->
Other -> Document -> Chapter -> Chapter Name - Set Level 3 -> Insert.
The Chapter Field can then be selected like any other text and Right
Justified and the font and font size can be chosen to match the book title
on the left hand pages.
Obtaining a Page Style Change
There are two ways to obtain a change of
page style. The first is to insert a Manual
Page Break before the change of Page Style
- a Page Break using a Ctrl Return is not
sufficient as you cannot choose the new
style. This is done by Insert -> Manual
Break and selecting Page and choosing the
Figure 24:
Style of the following page as in the
example for a page with a heading. Also
note that there is an option so you can change the page number. The only
time you do that is when you have finished the ‘Front matter’ and are
starting on the main body of the book which is in chapters. The Front
matter, by convention has Roman Numerals and the Main Body starts
from 1 in Arabic numerals.
The second way is via the options associated with a Paragraph Style
under the Text Flow tab:

Figure 25
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You will see that we have checked the Insert and With Page Styles boxes
and chosen the style for a Heading Page and asked for the Page break to
be before the start of the paragraph. Also note that we could ask for a
change in Page number (0 is no change) so this also allows us to make the
change in page numbering between the Front matter and the Chapters of
the book.
Flow in a Heading Style provides
Tip anTheeasyusewayof toTexthandle
the paging for the chapters of
a book. Each chapter has a chapter heading, which, in our
case, has Heading 3 Style. The Heading 3 Style, like any other
paragraph style, can be set up to control the text flow which
allows us to automatically force a new page when we enter
the chapter heading at the start of a new Chapter. The Text
Flow tab for the Heading 3 Style will look as in Figure 25.
You can, of course, still make changes to an individual
paragraph to handle the change in page numbering as you
leave the Front Matter.
You do not need to generally change the style following a Heading Page as
you will recall we set up the Organiser tab for the Heading Page to set the
following Page to have Style Default. If it is in the Front Matter and Back
Matter areas we do need to use a Manual Page Break to change the Style
and it is probably safer to always do so. Unfortunately the Manual Page
Breaks do not appear as a field which you can see although the top margin
outline is slightly thicker and blue coloured by default. I like to make it
more obvious by changing the colour to a bright green by View →
Options → OpenOffice.org → Appearance → Text Document → Page
and Section Breaks → Light Green
Other codes and fields can be made visible by a combination of Tools
-> Options -> OpenOffice.org Writer -> Formatting Aids and View ->
Options .
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12 Page Numbering
Page numbering is very simple in OpenOffice Writer. A page number can
be inserted anywhere in a document using a feature called Fields and will
automatically update as the document grows and shrinks. It is normal to
insert it in the Header or Footer of the document, the special areas at the
top and bottom which are the same on every page in a sequence.
Firstly I will give instructions on how to insert a page number to show
how simple it is then give some background information on Fields as you
will need them for other purposes in anything more complex than a novel
Lets put a page number in the Footer and centre it:
Click in the Footer area.
Insert -. Fields → Page Number and there it is.
View → Field Shadings will toggle a grey background behind all
fields so you know that a piece of text or number is actually a field.
Leave it on.
Highlight the number and click centre and it will be in the middle of
the Footer.
Add a - either side so it looks like - 3 - to make it pretty.
Now look down the subsequent pages and you will see the pages are
all the same.
If every other page number is missing you have the Page set up for
different Footers on left and right pages and you can either change
that (see Chapter 11 Page Styles for the Book )or add it to the other
page – if you do that you can have them at the right and left edges.
Changing the Page number format and resetting the Page
Number
The Page Number Field we have inserted has the format specified in the
Page Style. We set that to Roman for our Front Matter Page Styles and
Arabic elsewhere so that is fine. But how
to we reset the page number between
the Front Matter and the subsequent
text? This is done with a Manual Page
Break which we enter by Insert →
Manual Page Break and set up as in
Figure 26, noting my main text for the
Figure 26
chapters has Style royal.

Page Numbering
You may have to delete an existing Page Break and
Tip re-insert
it as there is no way of editing a Manual
Page Break
Background on Fields
Fields are extremely useful features of Writer. They are used for a variety
of purposes; for example, data that changes (such as the current date or
the total number of pages) or might change (the name of a product or
book under development), user-defined numbering sequences, automatic
cross-references, and conditional content (words or paragraphs that are
visible or printed in some conditions but not others). Index entries are
also fields.
The most popular Fields can be accessed quickly via Insert → Field.
There are a huge range of additional
and useful fields accessed by Other
at the bottom of the list which can
be used in a book, for example, for
adding a Chapter Heading to a
Header which automatically updates
in each chapter, Cross references to
a topic and many more. I will show
you how to use a few of these for
Figure 27:
more advanced books.
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13 Document Outlines and the Table of Contents.
Introduction to the Document Outline
Every document in OpenOffice has an Outline but its presence and
importance is far from obvious in simple documents. The Outline is what
determines the layout in the Table of Contents and determines much of
the automatic numbering in headings - neither are present or active by
default so the importance of the Outline is not apparent initially and it is
only when one come to do ‘clever’ things that it all becomes obvious, or in
my case obscure!
The Outline the mechanism which provides a hierarchical structure to a
document so that a Table of Contents can lay out the various levels of
Headings below each other. There are 10 levels available but you will
rarely need that many. You might have levels for Parts, Chapters, Sections
and Subsections and automatically label a subsection 2.3.1. The
explanation that follows may be a simplification but it got me to the point
where I understood enough for laying out the book.
OpenOffice gives you a very good start as the defaults provide a good a
basic hierarchical structure which you can adapt to what you need – in
many cases no changes or only very minor changes will be required. For
example there are Styles defined for Headings at every level which you can
use. The Chapter title the top of this page uses Style Heading 3 and all I
need to do whenever I need another Chapter is to type in the title, leave
the cursor anywhere in it and set the Style to Heading 3.
In this chapter I am going to make the assumption that we will use the
Style Heading 3 for our chapter headings in the book and that we want to
have the chapter number automatically added to the text we enter for each
Chapter Title and in the Table of Contents]
To reiterate, the pre-defined Heading Styles are directly related to the
Levels in the Outline - every time you add a Heading x (where x is 1 to 10)
to your Document you add another entry to the document Outline at level
x. In a default situation everything which is in the document Outline is
also in the Table of Contents (TOC).
The initial Styles for the various Heading levels are defined and these
map onto another set of pre-defined Styles which are used in the Table of
Contents ie the Heading 3 style, which is about right for a book chapter,
will be mapped to a style called Contents 3 which again will look sensible
in our contents list. I have made some minor modifications to the styles
for Heading 3 and Contents 3 to suit your exact requirements in the book.
I have already covered the modifications to Heading 3 and Contents 3 as
exapmples of setting up Styles earlier in Chapter 10 in the section An
Example – The Heading 3 Style used for Chapter Titles. It is possible to
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add automatic numbering to both the Contents and the Headings and I
will cover that next.
Adding Chapter Numbers to you Headings
Initially there are no numbers displayed with these Heading or Contents
styles. The numbers can be set up using Tools → Outline Numbering. In
the Outline Numbering you become fully aware of Levels and how they
map the Heading Styles to the Contents Styles - Heading 3 by default is
linked to Level 3 of the Outline. See below for how I have it set up for
Level 3. Only Level 3 is changed from the defaults and looks like the
following:

Figure 29
Figure 28
You will note that I have specified the Number using the drop down list
on the first tab and on the second I have set that the number is followed
by a tab to space it away to an absolute position of 1.4 cms and also an
indent of 1.4 cms to align the text if it is more than one line in length.
After this the display of a Heading 3 has a number in front of it in the
body of the text.
We now need to insert a Table of Contents at the front of the book by
Insert → Indexes and Tables → Indexes and Tables. We get the following
when we look at the Index/Table Tab which needs no changes.

Figure 30:
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We now need to look at the Entries Tab which initially looks like the
following when we click on Level 3:

Figure 31
The changes needed to format the Table of Contents Entries do not
follow any standard method I have met. The line called Structure is what
does the work and you can find out what is there and what it does by
hovering over each entry.
We now want to separate the Chapter Number and the Entry text by a
Tab Stop which we will need to add. Click the box between the E# and
the E then click the Tab Stop Button after which we get a display like the
following which includes our new Tab:

Figure 32
You will see that a new entry has appeared in the Structure with a T in it. I
have already set the Tab Stop position to 0.80 cms.
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If you want to edit this (or the tab at the end) then you click on the
T to get the configuration as displayed.
If you want to delete an entry completely click on it then hit the
Delete key on your keyboard which will remove it completely.
You do not need to change the other 3 tabs (Styles, Columns and
Background).
If you want to make changes to an existing TOC right click anywhere on
it and click Edit Index/Table to get back to the above display.
Assuming we only use Heading 3 we are now set for automatic numbering
in both the Headings and Table of Contents.
Headings for Parts, Front Matter and Back Matter – a Simple
Approach.
We now need to look at the ‘Headings’ for all the other pages in the Front
Matter and the Back Matter and displaying them in the Table of Contents.
It would seem logical to add these as more Heading 3s but that does not
work as they will then also be numbered which we do not want. Parts are
another problem as logically they should be at a higher level such as Level
2 with Heading 2 etc. but that will reset the chapter numbering in each
Part which we do not want.
way round this is for Parts to use Headings
Tip at simple
a lower level such as to avoid them resetting the
A

numbering of the Chapters.
It took me a long time to realise that this seemingly back to front way was
the only easy way to avoid the number sequence being disturbed.
I have used a Heading 4 Style for the titles of the Parts of the book.
The Styles for Heading 4 and Content 4 had to be changed to give
sensible displays in the book and in the Table of Contents ie larger text
and less indent than those I was using for Header 3 and Content 3.
I then found that I needed a Style for headings such as Appendices, and
I used the Heading 5 Style and configured the Heading 5 and Contents 5
Styles to closely match what I was using for Headings 3 and Contents 3.
Subheadings and Subsubheadings use Heading 6 and Heading 7 Styles
and the match Contents 6 and Contents 7 Styles in the TOC.
I cover numbering in Appendices in Chapter 15 ‘Numbering Appendices,
an example of using Fields’ on page 59 and a more elegant but normally
unnecessary way to use a more appropriate level for the Parts is in
Chapter 18 ‘Adding Part Headings to the TOC using an Index Entry’ on
page 67. This method may have advantages if you have a complex
hierarchical structure in your book or are just a perfectionist like me!
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14 The Navigator

To change to the controls for a category, click the Navigator button, the
second button on the top left of the Navigator window. You can change
the amount of objects shown by adjusting how many levels you want to
work with in the Navigator window. For example, if you only want to
work with items on the main or first level, like items in Heading 1 and
Heading 2, but not sublevels, select 1 from the Heading Levels Shown
drop-down list.
To skip to a certain page in the document, you can type a page number
into the text box to the left of the Drag Mode drop-down list and hit the
Enter key. You can also use the up and down arrows of the field to
navigate the pages. We’ll leave you with one last tip: right-clicking on
objects in the Navigator window gives you a few more options to explore.
OpenOffice has a very powerful tool
for navigating, that is moving around,
a large document called the
Navigator. It is turned on and off by
the gold star shaped button on the
Standard Toolbar. It appears first
time as a floating tool but can be
docked by dragging it to either side.
The Navigator is very useful, if not
essential, in larger documents such as
books, chapters, manuals, and long
reports. If you have a large wide
screen it is sensible to keep it
permanently docked along with the
Styles and Formatting Window as
they will both be used a lot whilst
working on a book. I have a 22inch
screen with a 1680x1050 resolution
which provides me to work with a
whole page displayed and the

Figure 33

The Navigator
Navigator and Styles Windows docked one above the other on the left
hand side of the screen.
The Navigator is a very powerful tool which amongst many things can
display the structure and all the different items that make up a document,
such as headings, tables, graphics, indices, objects and hyperlinks - you can
go to any one of them by double clicking on it in the Navigator. The
button on the bottom one from the left (content view) controls this
feature among with the drop down button (Heading Levels Shown).
Moving quickly through a document
The Navigator provides many ways to move around a document and find
items in it. You can:
type the page number in the box at the top of the Navigator.
double-click on an object to jump directly to that object’s location in
the document.
change the number of Heading levels shown (button third from
right on bottom row).
restrict the number of categories in view by highlighting a category
and clicking the Content View icon second button on bottom row)
and Click again to display all the categories.
jump to the header and footer using the buttons third and fourth
from the left on the bottom row.
use the Previous and Next icons (third and fourth buttons top row)
to jump to other objects of the type selected in the Navigation
Toolbar which you can reach from the second button on top row.
The last feature is duplicated on the
bottom right of screen between the
Double Up and Down arrows. The
Double Up and Down arrows then
move you through the document in the
same way which is useful when the
Navigator is not open.

Figure 34:

Rearranging Chapters using the Navigator
In addition to being able to navigate the document easily, you can
manipulate the document with Navigator. It is easy to rearrange chapters
and move headings in the document by using the Navigator.
Click on the heading of the block of text that you want to move and
drag the heading to a new location on the Navigator. All of the text
and subsections under the selected heading move with it.
You can change the Levels of Headings. For instance, a section
within Chapter 13 has become to long and you want to make it a
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separate chapter. Instead of copying and pasting the content into
the right place and then changing the heading style or level, you can
use the Promote and Demote Level buttons (last two buttons on the
top row). This action does not change the location of the heading,
only its level.
To increase the outline level of only the selected heading, but not its
associated subheadings, hold down Control, and then click the icon.
Setting Reminders
Reminders are a feature of OpenOffice Writer which few people find.
They can be used to mark your place in the document so you can return
to it. OpenOffice does not have any form of ‘back’ feature that I can find
so Reminders are very useful. Reminders are not highlighted in any way in
the document, so you cannot see where they are.
To set a reminder at the cursor's current location, click on the icon in
the Navigator which looks like a Paperclip (which is third from right on
bottom row). You can set up to 5 reminders in a document (setting
another causes the first to be deleted). To jump between reminders, first
select the same icon on the Navigation Toolbar. Now the Previous and
Next icons in the Navigator or on screen are active for reminders.
Drag and Drop from the Navigator
The last feature of the Navigator is that you can Drag and Drop from
the Navigator into the document. There are three modes:
Insert as Hyperlink: This creates a hyperlink when you drag and
drop an item into the current document.
Insert as Link: This inserts the selected item as a link where you
drag and drop an object into the current document.
Insert as Copy: This inserts a copy of the selected item where you
drag and drop in the current document.
This is possibly the least useful feature as there are restrictions, including
that you cannot drag and drop links or copies of graphics, OLE objects,
or indexes, only Hyperlinks to them.
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15 Numbering Appendices, an example of using
Fields
Introduction to using Fields
The automatic numbering scheme available for headers and in the Table
of Contents works well for a simple layout but what do you do if you
want several different numbering schemes in different parts of the book?
OpenOffice provides a powerful general purpose facility called Fields
which enables us to add sequences of numbers (and many other things)
into special areas in the text called Fields. Many of these Fields are predefined and are used, for example, for page numbers and adding chapter
headings to our pages.
One can also create ones own fields for Variables which can be used for
Chapter and Appendix numbers. You can access this facility by Insert →
Fields → Other → the Variables tab. For the purpose of numbering an
Appendix we obviously want our field to hold a number so we select
Number range on the Type drop down box. The first time we use our
Variable we have to type its name into the Name box, after that it will be
added to the Selection list available so we just have to select it in the
Selection list. We also need to select the Format – for an Appendix we will
want it to be a Capital Letter (A B C)

Figure 35
You will see in Figure 35 that there are a number of fields available,
most of them were already set up in the system – I have just the added
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ones for Appendix and Chapter. You do not normally need to fill in the
Value unless you want to start at a different number or reset it at some
point to change the sequence. You could for example use the same
Variable for Chapter number and Appendix number and just type in 1 and
change the Format for the first Appendix. When you click Insert it adds
the Field to your text at the cursor position and the Window stays open so
you can make further insertions if you need to.
If you hover over the Field you have inserted you will see the default
Value is Appendix+1 if you do not set a Value – this is how it increments.
It is useful to be able to see what is going on and there are some View
options to help. It is a very good idea to have View → Field shadings
always checked – this gives a grey background to Fields so you can see
what is text generated from a Field and what is ‘real’ text.
You can also display the Details of the Field by View → Field Names
can be checked and the Details of the Field will be displayed instead of
the ‘value’ - this is useful when examining somebody else’s document but
will cause you great confusion if you leave it checked especially if Field
shadings is not checked!
The best way to understand is to experiment so try setting up a variable
in a new document, insert it a few times in different places so you can see
how it updates and also try the various settings available using the View
drop-down menu. It will then become very obvious and simple.
Using a Field for numbering an Appendix
I use the mechanisms built in for numbering in Headers and the Table of
Contents as it gives a good layout when you want the number to be before
the title. It does not work so well for an Appendix where you want the
letter to follow the word Appendix. Using the Numeric range Variable
Field we created above is ideal for an Appendix and you will see in this
document that I use a two line Appendix heading. The Appendix headings
need a different Style to the Chapter headings so use a Header 5 Style so
the heading and Table of Contents entries can be ‘formatted’ separately
from the Chapters.
There are some quirks in how text is handled in the Table of Contents
and in other Fields such as that used in a Header. In the Table of
Contents tabs are converted to spaces but line-breaks are used. In the
Chapter Field we used earlier in our headers both tabs and line-breaks are
ignored.
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16 Entering Cross-references to Figures, Tables etc.
References to Figures
If we want to frequently refer to figures in the text they need a Caption.
We can automatically add a caption and number to every Picture we insert
by setting up the Options (Tools → Options → OpenOffice.org Writer
→ AutoCaption as per Figure 36

Figure 36
We can now insert our cross reference as a Field by Insert → Fields →
Other → Cross-references; select Figure under Type, select Figure under
Selection and select Category and Number under Insert reference to - see
Figure 37 . It will be much easier to see what is going on if you have
turned on Field Shadings by View → check Field Shadings box

Open Secrets Publishing with Style using OpenSource Software

Figure 37
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17 Alphabetical Indexes
OpenOffice makes it relatively easy to set up an alphabetical index – you
can highlight a word or phrase and add it to an index in a few key strokes.
You can also automatically add all other occurances of the word or phrase
at the same time. The phrase is highlighted and the entry window is
opened by Insert → Indexes and Tables → Entry – in Figure 38 the
phrase alphabetical index was highlighted and I have also it search and
apply to all similar texts.

Figure 38
The enrty window can be kept open as you add more entries by
highlighting them and clcking back anywhere on the entry window.
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You can then insert the alphabetical index itself with a few more key
strokes by Insert → Indexes and Tables → Indexes and tables which
takes you to the same Window as for a Table of Contents – the only
difference is that you have to select Alphabetical Index from the drop
down list as below

Figure 39

We will need to change the layout of the table using the Entries tab which
should look like this:

Figure 40
Note that all the levels have the same Structure and formatting – the tab
has been deleted by clicking on it and hitting delete on the keyboard and
an extra space has been added in the box between the E and the #
buttons. The Alphabetical delimeter box has been checked
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We will now set up to have a double column index on the Columns tab
which should look like Figure 41

Figure 41
And that should be it.
After any changes in the text or the Formatting of the Index you need to
update it by right clicking anywhere on it → Update Index/Table
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18 Adding Part Headings to the TOC using an Index
Entry
We looked at a way of keeping Chapter numbering from Part to Part by a
fudge by demoting them to a low level.
There is an alternative by adding the Part heading to the TOC as an
Index Entry at a more appropriate level. This may have advantages if you
have a complex hierarchical structure in your book or are just a
perfectionist.
First you must you must check that the facility is enabled in the Table of
Contents to create the TOC from Index Marks as well Outlines see below.

Figure 42
Now we highlight each Parts Heading in turn and do Insert → Indexes
and Tables → Entry and select Table of Contents from the Index dropdown and the Level you want – I have used level 1 in my example.

Figure 43
When you update the Table of Contents (Right Click → Update) you will
find the entry has appeared.
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You now have to adjust the Style for the TOC entry for level 1 which is
Contents 1 so you have the Indents and Font you want and the Structure
and Formatting of the entry by Right clicking on the TOC → Edit →
Entries tab and setting up the level used as below:

Figure 44
I have deleted the Entry Number otherwise the settings remain as per
the defaults.
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19 Fonts acceptable to Lulu
The following are eaxmples of the fonts which Lulu say are acceptable for
use in their document conversion programs and for publication under the
Published By Lulu and Published By You sales packages:
Arial
this
is
an
example
of
Arial
abcdefghijklmnopqrstuvwxyz1234567890-=!"£$
%^&*()_+ABCDEFGHIJKLMNOPQRSTUVWXYZ
Book Antiqua - this is an example of Book Antiqua
abcdefghijklmnopqrstuvwxyz1234567890-=!"£$
%^&*()_+ABCDEFGHIJKLMNOPQRSTUVWXYZ
Bookman Old Style - this is an example of Bookman Old Style
abcdefghijklmnopqrstuvwxyz1234567890-=!"£$
%^&*()_+ABCDEFGHIJKLMNOPQRSTUVWXYZ
Century

this
is
an
example
of
Century
abcdefghijklmnopqrstuvwxyz1234567890=!"£$
%^&*()_+ABCDEFGHIJKLMNOPQRSTUVWXYZ
Courier
this
is
an
example
of
Courier
abcdefghijklmnopqrstuvwxyz1234567890-=!"£$
%^&*()_+ABCDEFGHIJKLMNOPQRSTUVWXYZ
Garamond
This
is
an
example
of
Garamond
abcdefghijklmnopqrstuvwxyz1234567890-=!"£$
%^&*()_+ABCDEFGHIJKLMNOPQRSTUVWXYZ
Palatino - this is an example of
Palatino Linotype
abcdefghijklmnopqrstuvwxyz1234567890-=!"£$
%^&*()_+ABCDEFGHIJKLMNOPQRSTUVWXYZ
Tahoma
this
is
an
example
of
Tahoma
abcdefghijklmnopqrstuvwxyz1234567890-=!"£$
%^&*()_+ABCDEFGHIJKLMNOPQRSTUVWXYZ
Times New Roman - this is an example of Times New Roman
abcdefghijklmnopqrstuvwxyz1234567890-=!"£$
%^&*()_+ABCDEFGHIJKLMNOPQRSTUVWXYZ
Verdana - this is an example of Verdana
abcdefghijklmnopqrstuvwxyz1234567890-=!"£$
%^&*()_+ABCDEFGHIJKLMNOPQRSTUVWXYZ
Symbols
Many of these are not standard in Ubuntu but can easily be added if
you have a dual booted system from the Windows font file. This is
covered in Appendix F Adding extra Fonts in Linux so they are
accessible from Open Office

20 Cover Page for Books on Lulu
Cover Pictures
I have been exploring the use of GIMP to produce the cover for
Pauline's Book. GIMP is not the easiest program to use as it goes back a
long way to before GUI interfaces had become reasonably standardised
between operating systems. It is however very powerful as I have
discovered in the past. This time I am using it in a different way to
previously and it took days to get up the learning curve to be able to do
anything useful including several hours working through the help system
and introductory tutorials. In particular I wanted to be able to use the
layers facility as I had the cover picture scanned in two parts and I wanted
to be able to merge them and then make the unpainted sky area
transparent so I could change the background under the text for the title,
subtitle and authors name. Each block of text you add in GIMP has its
own transparent layer with the text in a font, colour etc of your choice but
not changeable within the block.
Lulu has two options of interest for creating a Cover using ones own
full size graphics - the first takes one or two full size graphics and I will
get to defining full size, and creates the spine with a Title, Author etc for
you. The second allows you to upload the completed cover including the
spine. The second needs you to calculate the width of the spine from the
number of pages and you also have to add all the back cover text to the
large graphic. The reason to use the second route is that it seems to be the
only way to add your own ISBN number rather than ones which they
issue in their own name as Publishers.
So what are the sizes needed? It is not just the final book size as there is
a certain amount of trimming after the book is bound which can take off
up to .25". Lulu provides various templates and information but the
bottom line is that the covers for a Royal size book need to be 1890 x
2835 pixels and set to 300 dpi - this gives an extra .15 inch on the
unbound edge and .25 for the top and bottom. Their template also
indicates that you should count the outermost 105 pixels as a buffer which
is clear of text. I have been working with an image of 2000 x 3000 to give
me some scope to trim at the end. I have decided on doing it in several
layers once I had combined my scans, a one off job. The layers are
Author text - white
Sub Title text - black
Title text - black
Pauline's Painting with a transparent area for the background
Sky 2 - Blue Colour - Transparency adjusted to lighten background

Cover Page for Books on Lulu
Background - White
If we make a full cover the layers will have to increase with a layer for the
spine ( a graphic???), another background colour or split the existing
background and layers for each set of text and graphics on the back cover
plus the graphic for the Barcode with the ISBN number. If the
background is the same under the spine and the back cover then we can
just make final adjustments on the edge of the back cover for a few pages
more or less.
The cover size for Royal is given in the cover tables at
http://www.lulu.com/uk/help/book_covers_faq#cover_dimensions to
be 6.265 x 9.459" or 15.91 x 24.024cm (1880 x 2837) and this is a very
good match to their template which you can download of 1890 x 2835
which is x 24.0 cm
Royal Word Processor Page and Full Cover Template Dimensions that I
use
Word Processor Custom Page: 15.60 cm x 23.40 cm
Full bleed cover image to upload to Lulu Cover creator (Lulu template)
1890 x 2835
Full page for the cover PDF: 31.8 cm + spine x 24.0 cm
Images for front or back as part of full page cover: 1880 x 2835 pixels
(15.91 x 24.0cm)
Lulu Cover Creator
Lulu offers a number of built in alternatives for producing your wrap
round cover. There are two different wizards which allow you to create a
cover without any of your own graphics or to add some of your own
graphics. They all seemed pretty garish and not consistent with the
previous book so we opted for the advanced single piece cover option
where you create a single PDF to upload.
There are a number of ‘tricks’ in laying out a book cover. Before
starting you need to know the exact size of the cover required. This is
provided by Lulu when you get to the over preparation stage in the
process. You can then insert an image exactly sized to match the front
cover and insert it on the right of an OpenOffice page which you set up.
If the number of pages changes you may need to make adjustments to the
sizes.
Background colour is where we first need a trick as the background
colour is normally only applied under the text area and not under the
margins. The trick is therefore to reduce the margins to the size that you
want covered by background colour ie left, top and bottom margins to
0.0cms and the right margin to make sure you have a text area extending
under the spine. You can then set a border for the page which is the same
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colour as the background and give this a border width to provide the text
area you require. The following screens shots will make it all clear:
First set the background colour:

Figure 45
Now set the size of the page and margins to define the area we want to be
the background colour ie the left side and extending under the spine.
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Figure 46
Define a border which is the same colour as the text and delineate the area
for text by setting the spacing to the contents. You will find there is a limit
of 5 cms hence the size large of the right margin above.

Figure 47
And we now have what we want.
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The Spine Text
Lulu has a calculator for the spine width which we used to get the exact
width once we knew the number of pages in the book. We first inserted
the spine text using a text box accessed via the Drawing Tools Toolbar in
OpenOffice and rotated it by 90 after the text has been inserted. The text
box can be then be exactly sized to match the spine using the various
numerical options rather than dragging the corners and after rotation can
be positioned exactly the same way.
We later found a better way with a narrow spine was to create it as an
image using the text tool in Gimp so we could get the exact size of text
and spacing between lines we wanted. We first created a background
which was the same colour as the text background and the exact size we
required, added each set of text for Title Subtitle, Author and Publisher
then rotated it and exported it as a JPEG (.jpg) file ready to Import into
OpenOffice for the cover.
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Appendices

Appendix A
Transferring Styles to a New Document or
Template
Background on Styles and Templates
In OpenOffice Styles are specific to a document which is as it should be in Microsoft Word you can find changes to one document or moving a
document between machines can completely change the formatting of a
different document. So if you have created styles for a book and want to
start a new book, you need to load your existing styles into your new
document or set up a Template.
A template is a model that you use to create further documents. In our
case we want to create a Template for a particular size of book and in the
future we can also create templates for other sizes of books. Templates
can be very powerful and it is even possible to change a book size just by
associating the document with a different template.
Templates can contain anything that regular documents can contain,
such as text, graphics, a set of styles, and user-specific setup information
such as measurement units, language, the default printer, and toolbar and
menu customization.
In fact, all documents in OpenOffice are based on templates. If you do
not specify a template when you start a new Writer document, the
document is based on the default template for text documents. If you
have not specified a default template, Writer uses the blank template for
text documents that is installed with OpenOffice.
You can create a Template directly from your existing document but this
is not always sensible if you already have a 300 page long book as it is
difficult to clean it all up in the new Template. The method following first
copies all styles, or groups of styles into a new document which you can
then use as a basis for your Template.
Transferring Styles from an existing Document into a different
Document.

1. Open or create the new document to copy your styles into.
2. Open the Styles and Formatting window (F5 or click the
Icon to the left of the Styles Drop down Box as usual)
3. Click on the New Style from Selection icon (far right) and
then on Load Styles
4. Assuming the styles you want are contained in a text
document, click on the From File button - a standard file
selection dialogue box will open, allowing you to select the
desired document. If the Styles are already in a Template
you can instead find and select the template containing the
styles you wish to copy.
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5. Check the boxes for the types of styles to be copied. If you
select Overwrite, the styles being copied will replace any
styles of the same names in the target document.
6. Click OK.
You now have a new document which has all your styles available to use.
This is now the time to create a Template so you can easily start lots
more books. You can also edit your Template and you will be given the
opportunity to transfer those changes into any documents you created
using that Template the next time you open it.
To create a template from a document.
A better approach is to create a Template from your existing document so
you can easily start lots more books based on the Template. You can edit
your Template and you will be given the opportunity to transfer those
changes into any documents you created using that Template the next
time you open it.
You can copy all your styles into a new document using the procedure
above, then create a template from it. This is fine if you have not spent
time customising a Table of Contents and Outline Numbering schemes
however you will get problems if you copy an existing TOC into this
‘empty’ Template.
Creating your Template directly from your document is, I believe, the
safest and most reliable way to reliably get a Template for a complex
document. It may take a while to delete all the content you do not want to
keep whilst making sure you still have the Table of Contents (TOC) and
also have some examples of every sort of page and heading to ensure that
the TOC works properly and all the Outline Numbering is preserved.
This is the procedure I use:
1. Open the document you want to make into a template.
2. Rename it to ensure the original stays intact.
3. Make sure you just have the content and styles that you want in
the template – this is the time to delete any styles you do not need
any more.
4. Delete the bulk of the content which you do not need
5. If you keep the Table of Contents you must also keep at least
one occurrence of every Heading Style you use (see Note below).
This helps preserve the formatting and Outline Numbering
schemes used in the TOC and in Headings.
6. You should not have an Index in the Template
7. In the case of a complex Template such as that for a book, it is
worth self-documenting the Template with some examples of
- 77 -

Open Secrets - Publishing with Style using Open Source Software
your Styles with a brief description of each into the Template to
aid their future use – keep this documentation together so it can
easily be deleted from documents based on the Template.
8. Make sure you have some empty lines at the start of the
Document as it is difficult to insert extra pages etc., in front of a
TOC if it is right at the start of a file.
9. From the main menu, choose File → Templates → Save. The
Templates dialogue box opens (see above)
10. In the New template field, type a name for the new template.
11. In the Categories list, select the category to which you want to
assign the template. (For example, to save the template in the “My
Templates” folder, click the My Templates category.)
12. Click OK.
Most settings that can be added to or modified in a document are saved in
a Template when you create it this way. For example:
Styles, including character, page, frame, numbering, and paragraph
styles.
Outline Numbering
Format and settings regarding indexes, tables, bibliographies and
the Table of Contents.
Printer settings.

Note

When you copy Styles or make a new
Template you do not automatically transfer all
your settings associated with Outline Numbering unless the
the new Template contain an example of each Heading Style
and the Table of Contents which you have set up as you
require. i.e. you cannot start with a completely empty
Template if you want to preserve the Numbering Options
used in your Outline and TOC in Documents based on the
Template. This is the case up to OpenOffice 3.1 but this
‘shortfall’ may change in the future.
Using your new Template to create a document.
1. From the main menu, File → New → Templates and Documents.
The Templates and Documents dialogue box opens.
2. Click the Template icon if it is not already selected. A list of
template folders appears in the centre box.
3. Double-click the folder that contains the template that you want
to use. A list of all the templates contained in that folder appears
in the centre box.
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4. Select the template that you want to use. You can preview the
selected template or view the template’s properties:
➢ To preview the template, click the Preview icon. A
preview of the template appears in the box on the right –
see below.
➢ To view the template’s properties, click the Document
Properties icon.
5. Click Open.

Figure 48:
Managing Templates
Once you have created your template you can access it to edit it, delete it,
export it etc. The template Organiser is accessed by File → Templates →
Organise. You can double click your My Templates Folder to display your
custom Templates and then right click to get a menu as in Figure 49
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Figure 49
If you change machine you will need to export your templates and then
import them on the other machine via a USB memory stick CD or similar.
You can do the export and import via the Commands drop down menu or
right clicking on the file to export or the folder you wish to import into.
You can edit the template and the next time you open any files based on
the template you will be asked if you want to use the updated template or
stay as you are.
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Converting an Existing Document
When you start reading this book you will probably already have written
a lot of your book and you may even have been using a different word
processor. OpenOffice can fortunately open files in most formats and
save files in common formats such as Microsoft Word 97/2003. There are
many dangers in continuing to work in a different format and it is best to
clean the document up as much as possible before you start. OpenOffice
has many tools to help you.
I like to have as clean a start as possible especially if it is not a document
I have written. If I have document from a different Word Processor I
open it and delete any existing Indexes and Tables of Content. I then the
copy the entire contents into a new document and save it. It is now time
to have a look at what Styles have been transferred and if they should be
kept – basic Styles such a Headers may be OK but we probably want to
remove all the others as they will be incompatible with a book.
There are many other points to look for such as:
Do you have empty paragraphs separating you paragraphs?
Have you got lots of dumb quotes?
Do you have paragraphs which start with tabs or multiple spaces?
If so, this is the time to try out AutoCorrect. AutoCorrect has two
modes, the one we have been using when it formats as one types and a
manual mode accessed by Format → AutoCorrect → Apply. Great care
normally has to be used with the manual mode as it can destroy all your
careful formatting in a single click if you have done a Select All! First we
need to set up AutoCorrect by Format → AutoCorrect → AutoCorrect
Options. See Figure 50 and Figure 51 for the settings I have used

Figure 51
Figure 50
You will note that there are many options available on the left side which
are the ones for a manual format. The most useful for an initial
conversion are:
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Remove Blank Paragraphs
Replace Custom Styles ( with Default Styles such as Text Body and
Text Indent to ‘purge’ the document of unknown inputs)
Delete tabs and spaces at end and start of lines
Replace "standard" with “custom” quotes
Set up for Automatic replacement of single
Tip 'standard'
quotes by ‘smart’ quotes on the Custom
Quotes tab before you do a manual AutoCorrect for a book.
There are many ‘corrections’ you can also apply at this time (which are
also available as you type). These need to be used with caution if you have
any program code, in particular those to do with Capitalisation.
The Concatenation of single lines into paragraphs is also useful if you
have text from a web site or that you have copied from a screen. But again
needs to be used on a small selection so I always leave it turned off – in
fact I disable them all to avoid an accidental use of a manual AutoCorrect.
It is now time to import all you own book Styles from an existing
document or Template – see Appendix A Transferring Styles to a New
Document or Template page 76 or start to generate them see Chapter 10
Introduction to Styles and Paragraph Styles on page 41.
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Appendix C
Modifying Text with Find & Replace including
the use of Regular Expressions
Regular expressions are a clever way to find & replace text (similar to
'wildcards'). Regular expressions can be both powerful and complex, and
are difficult for inexperienced users to understand. I will limit my
description to some simple applications which are mostly of use in
putting text into a standard format. They are in common use in some
areas of computing and books are written solely covering their use.
When using OpenOffice.org Writer, Regular Expressions may be used
in the Search For box but, in general, they may not be used in the Replace
With box. In Writer regular expressions usually divide the text to be
searched into paragraphs which are treated separately and in addition
Writer considers each table cell and each text frame separately.
Find & Replace is used so much it has its own button in OpenOffice
and can also be accessed by Cntl F in most Word Processors and Editors.
You need to click the More Options button to get the full Find & Replace
Window which allows one to Search for Styles and use Regular
Expressions in the Search boxes. See Figure 52 for an example where we
are searching for an empty paragraphs used as a separators in text we have
imported.

Figure 52
The following is a good Link for introductory information on Regular
expressions:
http://wiki.services.openoffice.org/wiki/Documentation/How_
Tos/Regular_Expressions_in_Writer
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Avoid using the Replace All button with regular
Tip expressions
- there are occasions when this will give
unexpected results. It is always best to use ‘Find All’, then see
what you have and then use ‘Replace’ or ‘Replace All’.
Remove empty paragraphs
^$ is regular expression for an empty paragraph. I have had
problems with a repeated Find & Replace with empty paragraphs so
do a Find All then a Replace. Very useful when you change from
text with a blank line after every paragraph. See also use of
AutoCorrect in Appendix B Converting an Existing Document on
page 81
Replace Default paragraph style by your custom style.
This is very useful but only works for paragraph styles. Use More
Options and and tick the style box and select the old and new styles
from the drop down boxes.
Remove spaces at end of paragraph
I have used the More Options and ticked Regular Expressions then
found space$ and replaced by an empty Replace box repeatedly.
Remove double spaces between Sentences
An ordinary Repeated Search and Replace for double spaces and
replace by single space.
Remove tabs and spaces at start of Paragraphs
^[\x0009 ] → empty replace box.
Other Miscellaneous replacements
Replace non-breaking spaces with regular spaces: [:space:] → space
Replace manual line breaks with paragraph breaks: \n → \n
Replace double smart quotes (aka book quotes or curly quotes) with
straight quotes (aka dumb quotes): [\x201C\x201D\x201F] → "
Replace single smart quotes with straight quotes
[\x2018\x2019\x201B] → '
Change double quotes and single quotes to smart quotes
First Find opening dumb double quotes ( "\< ) with the regular
expressions box checked, since opening quotes are most likely to
come right before a word and Replace with a smart opening quote “
- you will need to create the opening and closing smart quotes and
copy and paste them into the replace field . Then Find all the
remaining dumb double quotes and Replace with a closing smart
quote. Depending on your consistency in writing it may be best to
do them individually rather than a Replace All.
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Repeat for single quotes - this will also correct dumb single quote
marks in abbreviations. In detail:
Make sure you have the AutoCorrect function to enable smart
quotes turned on
Type any word with quotes round it so you generate some smart
quotes you can cut and paste as required.
Highlight the left smart quote (“).
Copy the selection to the clipboard (Right click menu or Ctrl+C).
Edit → Find & Replace from the menu.
Paste the “ from the clipboard contents into the Replace with field
(right clicking menu or Ctrl+V)
type "\< in the Search for field.
Press the More Options button.
Check the box Regular Expressions.
Click the Find All button.
Click the Replace All button.
Highlight the right smart quote (”).
Copy the selection to the clipboard.
In the Search for field, type a single dumb quote (").
In the Replace with field, paste the ” from the clipboard.
Click the Find All button.
Click the Replace All button.

Repeat all the above using single quotes instead of double quotes.
Find Duplicate words separated by spaces
Put this magic string in the find box and click More Options and
check the Regular Expressions Box
\<([^ ]+)[ ]+\1
(note that there is a space before each ])
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Appendix D
Adding a Grammar Checker to Open Office
This is appropriate to versions 3.01 and 3.1 of OpenOffice
Open Office does not have a Grammar checker built in but it is possible
to add one as an Extension. The mechanism for Extensions is built into
OpenOffice but the Extensions are written by individuals or groups - this
is a beauty of OpenSource but one is vulnerable to the quality and
support level. At the worst one can always remove or disable the
Extension but I would always recommend not working on ‘live’
documents when testing any new feature. In the case of Grammar
checking it was always intended that one would be available and all the
menu entries etc are already built in and ready to go
The Grammar Checker for OpenOffice is called LanguageTool. To
loosely quote:
“LanguageTool is an Open Source language checker for English,
German, Polish, Dutch, and other languages. It is rule-based, which
means it will find errors for which a rule is defined in its XML
configuration files (and there are close to 500 rules implemented for
English). Rules for more complicated errors can be written in Java.
You can think of LanguageTool as a tool to detect errors that a
simple spell checker cannot detect, e.g. mixing up there/their,
no/now etc. It can also detect some grammar mistakes.”
The extension is in the main library of OpenOffice Extensions and is
called LanguageTool. It has been downloaded by over 100,000 people and
gets good marks so it is reasonably well thought of! It is at
http://extensions.services.openoffice.org/project/languagetool and has
had many years of development under OpenOffice 2.x.
LanguageTool needs to
Tip Microsystems
installed on

have Java from Sun
the machine you are
using, which is likely and a Java Runtime environment of 5.0
or later selected before you install this extension. This is set
by Tools -> Options -> Java in any OpenOffice program you will have to wait a long time and the version 5 is 1.50_xx
and you are likely to have version 6 1.60_xx. Versions of Java
less than 1.50_xx may fail to work and in version 6 you need
higher than 1.60_04.
If you are using Ubuntu then you must also add the
Tip java
package to OpenOffice as it is not installed in
Ubuntu by default. System -> Administration -> Synaptic
Package Manager and Search for and Install openoffice.orgjava-common before proceeding.
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To Install, download the file from the site and Double click
LanguageTool-0.9.9.oxt to install it. If that doesn’t work, call Tools ->
Extension Manager -> Add... to install it. Close OpenOffice.org and restart it. Type some text with an error (e.g. ‘This is an test test.’ - make sure
the text language is set to English) and you should see a blue underline.
There have been problems with
Warning LanguageTool
if you make any version
upgrades to OpenOffice without first uninstalling
LanguageTool. It can no longer be uninstalled to sort them
out - you may have to reload the earlier version of
OpenOffice and then remove it, assuming you still have the
earlier version. There is a risk with some systems that
upgrades take place automatically. This seems to have mainly
been a problem after OpenOffice 3.0 came out with the first
integration of grammar tools alongside the existing
dictionaries and these mechanisms were changed in
OpenOffice in the upgrade to 3.01 - now everything seems
much more stable from the OpenOffice end.
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Appendix E
Upgrading to the latest OpenOffice 3.x under
Ubuntu Linux
Ubuntu does not automatically upgrade to the latest issue of
OpenOffice, it just applies any updates to the version which came with
the original Distribution ie 2.4 in the case of Hardy Heron. There are
advantages in some cases in upgrading to version 3.x which is in Jaunty.
There is now a repository set up for the latest versions of OpenOffice
which can be used to keep OpenOffice updated automatically. This is the
Personal Package Archive PPA set up by the Openoffice Scribblers - see
https://launchpad.net/~openoffice-pkgs/+archive/ppa
and
http://www.rebelzero.com/ubuntu/ppa-for-openofficeorg-301-forhardyintrepid/94.
The way to include this repository is to:
Add the OpenOffice PPA repository to your sources.list file by
System > Administration > Software Sources. Click on the ThirdParty Software tab and click the Add… button. Copy the PPA’s
repository address in the APT Line box, and click the Add Source
button. Hardy users should use:
deb http://ppa.launchpad.net/openofficepkgs/ppa/ubuntu hardy main
Replace hardy by jaunty or the version you are using as appropriate
You will be asked to update the repository list
Next it is important that you click on the Ubuntu Software tab and
make sure the universe repository is enabled as the PPA packages
need some hardy packages from that repository.
Next you need to add the authentication keys for this repository, this
is most easily done in a terminal by:
sudo apt-key adv --keyserver keyserver.ubuntu.com --recvkeys 247D1CFF
You can use the Synaptic Package Manager to update everything
(Add/Remove was not happy with these changes until I had used
Synaptic). System -> Administration -> Synaptic Package Manager
First update the package lists by clicking Reload
Then click Mark all Possible upgrades which should show all the
ones for Open Office upgrade and click Apply.
You should now find that OpenOffice has been upgraded.

Appendix F
Adding extra Fonts in Linux so they are
accessible from Open Office
Some of the fonts used by Lulu are not standard in Linux so also need to
be added.
There should be no licence issues in using them on a dual
booted machine with a valid copy of Windows. You can find the
Garamond, Tahoma and other fonts in C:\Windows\Fonts. In Linux
(Ubuntu), The True Type fonts which are available to all users are stored
in folders under /usr/share/fonts/truetype so:
Type in a terminal:
gksudo nautilus /usr/share/fonts/truetype

Create a new folder for your extra fonts called ttf-extra by a right
click → Create Folder.
Drag the extra fonts into the ttf-extra folder from where they were
stored ( C:\Windows\Fonts)
Then alert the kernel that you added the fonts by typing the
following in a terminal
sudo fc-cache -f -v

The last command rebuilds the font cache - the options are verbose and
to force complete regeneration of the cache (neither may be necessary but
I followed the instructions before reading the manual page)
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